EasyCFM.COM ColdFusion Forums / Flex Development / Strange error : Could not find the included templa

   Reply to Discussion | New Discussion << previous || next >> 
Posted By Discussion Topic: Strange error : Could not find the included templa

book mark this topic Printer-friendly Version  send this discussion to a friend  new posts last

falconseye
10-07-2009 @ 11:18 AM
Reply
Edit
Profile
Send P.M.
My Gravatar!
Powered by Gravatar
Senior Member
Posts: 1033
Joined: Mar 2004

I am working on a flex application. I got four comboboxes which are using cfc methods in order to get their values. Everything was working locally. On the dev server, I get this error:



Could not find the included template /flex2gateway.



When I googled this problem, I found several things:

1. http://server/flex2gateway does bring a blank page up

2. flash remoting is checked in cf admin

3. i created a test.cfm and called the cfc/methods without any errors. the test.cfm is located where my .mxml file is.



So, I am not sure what else to do at this point. Any suggestions ?

thanks in advance.

falconseye
10-07-2009 @ 11:27 AM
Reply
Edit
Profile
Send P.M.
My Gravatar!
Powered by Gravatar
Senior Member
Posts: 1033
Joined: Mar 2004

ay caramba!

here is the solution:

<!--- Run before the request is processed --->
     <cffunction name="onRequestStart" returnType="boolean" output="false">
          <cfargument name="thePage" type="string" required="true">
        <!--- Me : 07-09-2009  --->
        <!--- onRequest breaks all flash remoting and remote CFC calls! --->
        <!--- added a work around ---->
        <cfif listlast(arguments.thePage,".") is "cfc" or findNoCase("/flex2gateway",arguments.thePage) gt 0>
               <cfset StructDelete(this, "onRequest") />
            <cfset StructDelete(variables,"onRequest")/>
        </cfif>

      
          <cfreturn true>
     </cffunction>


http://www.fuzzysiberians.com


Website Designed and Developed by Pablo Varando.