EasyCFM.COM ColdFusion Forums / ColdFusion Server / CF9 install on Windows 7

   Reply to Discussion | New Discussion << previous || next >> 
Posted By Discussion Topic: CF9 install on Windows 7

book mark this topic Printer-friendly Version  send this discussion to a friend  new posts last

dspent
05-14-2010 @ 11:01 PM
Reply
Edit
Profile
Send P.M.
My Gravatar!
Powered by Gravatar
Junior Member
Posts: 114
Joined: Nov 2004

I am trying to install CF9 onto my Win 7 32Bit pc.  I downloaded the install and got the huge 440MB+ file called Coldfusion_9_WWE_win.exe



I double-click that file and after a few seconds I see the InstallAnywhere app begin to extract the files....  After that completes, I see a JAVA icon pop up in the taskbar and from that point on nothing happens.  I did this a few times and on the last go I just let it run when I left for work.  When I came back home about 10 hours later, it was still doing nothing.  I checked the running processes and both Coldfusion_9_WWE_win.exe and Adobe_cf.exe are running but obviously nothing is getting installed.



I tried running it as administrator as well and that doesn't work either.  What else can I do?

Webmaster
05-14-2010 @ 11:16 PM
Reply
Edit
Profile
Send P.M.
My Gravatar!
Powered by Gravatar
Administrator
Posts: 4542
Joined: Jan 2002

try re-downloading it. there is a video on installing CF
on Win on ColdFusion.TV. That might help.

www.coldfusion.tv

Pablo Varando
Senior Application Architect
EasyCFM.COM, LLC.

904.483.1457 \\ mobile
webmaster@easycfm.com \\email

\m/ (>.<) \m/
--- rock on ---

dspent
05-14-2010 @ 11:33 PM
Reply
Edit
Profile
Send P.M.
My Gravatar!
Powered by Gravatar
Junior Member
Posts: 114
Joined: Nov 2004

already downloaded it twice.  The video did let me know I missed adding the IIS 6 metabase piece but even after adding that it still won't install.

dspent
05-15-2010 @ 5:08 AM
Reply
Edit
Profile
Send P.M.
My Gravatar!
Powered by Gravatar
Junior Member
Posts: 114
Joined: Nov 2004

Well - Just in case anyone else has this problem - I found the reason it was failing AND more importantly the

fix....



So I extracted everything from the ColdFusion_9_WWE_win.exe file to see if maybe I could execute the install.  When you extract the file you get two folders:



InstallerData

Windows



Inside the Windows folder is the adobe_cf.exe file  When I clicked it, I noticed that almost immediately it wrote 3 files.  two files with a long number string and a .details and .notes extenstion and another called centaur_err.  When I checked these files I noticed some java errors - mainly the following:



java.lang.nullpointerexception



This got me thinking that maybe my installed version of Java was not playing nicely with the installer.  So I checked my java version by going to the control panel and opening the JAVA control panel.  I clicked about and it showed I had Java.Version 1.6.0_16.  I then checked to see if there was an update.  There was - to version 1.6.0_20.  OK, so I updated Java.  I then deleted those 3 files that were written at the last botched install.  I kicked off adobe_cf.exe again.... Same crash - but something important stuck out....  SAME JAVA VERSION REPORTED - 1.6.0_16 not the newly updated version 1.6.0_20.



Could it be, the installer had cached my old version, or was it just not looking in the correct spot??????  There is one more file in the Windows directory that gets extracted, it is called adobe_cf.lax.  Let's check that one and see what's in it????  Low and behold there is the following line in this file:


lax.nl.current.vm=resource\\jre\\bin\\java.exe



I changed this entry to point to my installation of JAVA ---- So my file now has this:



lax.nl.current.vm=c:\\Program Files\\Java\\jre6\\bin\\java.exe



I saved the file and ran adobe_cf.exe again, and YAY!!!!!! my install now works perfectly.


Website Designed and Developed by Pablo Varando.